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n �������� ������������������������������������������������������������
���������������������#������������������������ 

n �������������8�������������������������������������������������������
����������� ������������������������������

n ������������������������;������� �������������� ������� �������������
���������2���������� ��������������������8������������2�����������������
��� ��������������������������8��

n �������������������;�������������������������������������������������
�� ���

n ��������������������������F���8�����G����������������������������������
�����������������������������8���

n ������� ������ ��������������������������� ���������������������
�����������

n ���������� ������������� ����������������������������������������#�������
������������ ���������

n !3/�����!����������#��������2���������&@/�

9
�9����������2�����������
����� ��� ��������������������������������������  ���������������
�����

n �/$�������������������������������������������������������������������������
���������������!������0���"/�$�������  ���������������������

������ �������������������
�!"���#�$
��������������������!"���#�$���6�78



&�������������������
�!"���#�$������������������ ����������������%

n ODGGHU�YLHZ���&�������������������������������������������������������
������ �������������� ��� %�������������������������������������%�

n UHVXOWV�ZLQGRZ���B�����������������������3����.��������������������������
�������%�K����������������������������������������� ����������������
��������������������������������������%�

n PHQX�EDU���!��������������������� ���� ��������������������������������
�������������������%���

n VWDQGDUG�WRROEDU�����������������������F�������������������� �����������G�
��������� ������������������������������������������������������������
����������������� %�&����������������������������������������������2�
�!"���#�$������������%������ �������������������������%�.������������������
�����������������������������������������������������%����

Add-in toolbarInstruction toolbar
Menu bar

Standard (Main) 
toolbar

Online bar

Project tree

Results window

Status bar

Ladder view
79��6����!"���#�$�������������������



n RQOLQH�EDU���"������������������ �����������������������������
���������������������������������%�K�������������������������������
�� ��%�

n LQVWUXFWLRQ�WRROEDU���B�������������������� � �����������������������%�
'�����������������������������������������������������8������������
�������������������������������������������%�/������������������������������
�������������������� %�

n DGG�LQ�WRROEDU���&���!"���#�$�����������������%�E������������������;�������
������������������������������!'���&?>�)�����%��

n VWDWXV�EDU���"������������������������������� ������������ ���2��������
�������������%��

n SURMHFW�WUHH���B���������������������������������������������������8��%����

&������������������ ������ ������������������������ �����������������
�� ������%�3���#� ��2������������������������������� ����2�������
�������������� 2����2����2������������������������������ ����2�
� ���������������%

This symbol ( - ) means that the folder’s 
contents are already visible. Click the 
symbol to collapse the folder and hide its 
contents.

This symbol ( + ) means that the 
folder’s contents are not visible. Click 
the symbol to expand the folder and 
reveal its contents.
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��	������������	���������
��	��
��������������� ����2��� ��������������������������������8�����%��������
���������������2���������������������������������������������������8�����%�
.����������������������� ����������������������� ����������������%�

������������	���	"����"���"

������� ������������������������ ����8��2�������������������������
������%�

�� ���������������������������������������������������������%����
���������������������������������������������%�

�� /�������������������������������������������������������������������
��������� ����%

�� '���������������������2���������������������� ��������������8������
��������������������%������������������������������������������%�

A���������������� ������������������������� ������������������
������� �����%�K�������������������������������������������� �
���������������������������� ������������������� �������������� ����%�

��	������������	���������"���"�

.������ ��������������� ������������� �������������������������
��������������%

�� &��������8������������������������������ ��������������������%�

�� !����New Window%�

�� ������������������������������������������ ����������������������
�� ����������%

���������������� �������2����������������������%�

Click a tab to view the file. 
To close a file, right-click its 
tab and select Remove.

Split bar
Cursor
7,��6����!"���#�$�������������������



K�������������������� ��������� ������������8����������������������
���������������!"���#�$��������������������������������������� ����%�K���
 �������� �����������������������!"���#�$������������ ����������8����
�������� ��� %�>�����������������8��������2������2��������������
�������������������������������������� %�

'���(���������	���
���	�	����	���
������������������#�����������������������������  ����;������������
�!"���#�$��������������������������%�

��	��7�?����
����	�����	����������������
B�����������������������������8��%���������������������������������������
������ ���������������8�������������������������������� ���������������
���������������� %�F,�� ����2����� ���  ��������������������������������
���8��%�/���������������8����������������������%�!������������
��  �������������������2����� ���  ��������������������������  �2�
����������������������������8��%�3��� �������� �����������������������
��������� �����������������  ����������2���/������92�)�����*�
��
$��&��
�����$�++
��$�����	������� �=%G

!����Tools > Options%�/��������!��� �/�  ���������������������!��� �
>�������������2����������������%�3�� �����������������������2����2����������
�� ���%���

Make your driver and 
node selections here.

If you have previously set up 
communications with a network 
node in RSLogix 5, you can 
select from a list of previously 
configured drivers and nodes.A driver must already have 

been configured in RSLinx or 
RSLinx Lite. If not, do so 
before performing this step. 
Refer to the online help in 
RSLinx for more information 
on configuring drivers. (Select 
driver configuration in the 
RSLinx help index).

You can also access the Who 
Active feature available in 
RSLinx. This utility displays all 
available stations/nodes on your 
communication networks. This 
can help if you are unsure of the 
node number of a particular 
device on the network.
��������������������!"���#�$���6��7:



��	��-�?���	��	����	"����/	��������	�����	��������
���/	��
�!"���#�$���������������8���%�.����8����������� �������������������������
���������������� ������%�

&	"����/	���

����������������8��(

�� !����File > New%

�� ������������ ��������������������������������!�����������������
������%�&���������������������  �����������������C�����!�����!���
2������
����� �������������������������%�&�����2�������������  �����������
����������%�/�����>D%

�!"���#�$��������������������������8�����������������������������8��%�
��������8����������������������������������� 2����������2�����������������%�
!���� 
$����� �������� ������������������8�����%

6�����������/	����

����������#����������8��(

�� !����File > Open%

�� /��������������������������������������Open%�&���������������������
����������������������������(

n E�����Look in��������������������������������������%

n E�����Files of type������������������������������#�����������������
%�!�2�%L$2�%�/$2����%.3$%

�!"���#�$������������8������������ ����������������������������
������������������!�������B>!������F�"/�$�.%&%�!�������<�		�!����
�"/�$G����'������������F�!"���#�$����'&,��������"�����$G�������  ����
�������%�&������#������������� ������2�����������������������������
����� �������������������������������������%�3��� �������� ������������
����������8�����������������������������!��������"/�$�������  ����
����������������2��������/������-2�,�������-.".���#���  ����/�$��&���	����
������� �������� 9
%��

Tip 3�������������������������������������������������#�������2�������
���Help��������������>��?& ������"/$������� �������%
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��	��8��?��!���	�������������2��
����������������(

�� 3�� ����/������������������������8�����2����������������&>�
/�����������������%����&?>�/���������������/�������������������
������%

�� ���������������������&?>�/�����������������������������Add Chassis%�
���@����/�������������������������#�������2���������/�����������
�����%

�� !������������������������������������������������������%�.���������
������������������������������������%

�� !������������������������ ��������%

�� &�����0����������3�#�&?>��������2���������� ������������������
Number of slots�����%�@�������������� �
����7%

�� B��� ������B&�����������������������������������������������������
����������������������#��������B&��!�����������������������������#%

�� /�����>D�������������������������������������������#%�

!� � ������ ����;��������������������������������������%�!�
/������$2�0��#�����$��&��
������������� 9$����� �������� ������������
���������������������%�

&RQWURO1HW�XVHUV��3���/������,�1�����������������������&?>�����
/������,�2���������������� ������ ������������ ���������!,�'��#1�
�����������������������������������������������������%�.���2����
����������%L/�����F����������!,�'��#G��������/������,�������� ���
��������������� ��������������/���������������������������8�����%�

By default the first 
chassis listed in a 
new project is the 
1771-A1B four slot. 
You can change this 
by right-clicking on 
the chassis and 
selecting Properties.

To add modules to the chassis, right-click the 
chassis and select Display Chassis. The 
smaller dialog shown here appears.

On the Chassis dialog, right-click in the cell for the 
slot to which you wish to add a module and select 
Insert Module.
��������������������!"���#�$���6��7<



��	��9��?����	��	������������������$�	�
��	��
������8������������������������������������������������������������
#�����������%�����������������2���������������������� ����������������������
���������New%�.�������������������������������������� ���������������
���%�3��� �������� �����2��������������������%�

.������� ����� �������������������������� ������F!K!�	G2���� ����������
������ �F".B��G2���������������������� %�

B������������������������������������� ���������������������#������&?>�����
������������������������������������� ������������������������������ �����%�
&����������2�������������������� ����������������������������������%�K���
�������������������������������������������������������%

��	�����?��6��	�����������������
'������������������� �����������������������������������������8�����2�
������������������������������������������!"���#�$�������%�E�������
������ �����N�2���� ���������� ����2��������������������������8��%�&��
���������������������������������������2��������������������������%���

��������������������������������� (

�� /������������������������������������������������������E�������
�������������������������%�

�� ��������������������������������2�����������������������������������������%�

K���������������������������������������������;�������������������
��������������������%��!"���#�$����������������������� �������������%

Right-click and select New 
to create a new program or 
data file.

Data files are also created 
automatically as you assign 
new addresses in your ladder 
program. 

If there are too many instructions on the toolbar 
to see all at once, use these arrows to scroll.

Each of these tabs displays 
a different category of 
instructions in the toolbar.

Use these arrows 
to scroll through 
the tabs.

New Rung 
icon
-.��6����!"���#�$�������������������



�� .����������������������������������%�B�������������������������2�����
���������������� ����������������������������������������2�����
��������@������%�'�����!"���#�$������������������������������������
��� ������������������������������������������������������%

�� /�������������������2��  ���������������������������������������
File > Save%

�!"���#�$��������������������������%������ ����������������(

n ��������?������� �������������������� 

n �����������������������������������������������������������&?>

n ������ ���������������������������������������� ��������������

n ��������������������������������������������������������8�������������
�����������������

3��� ��������������� �����������������������������������������
����� ���������������������2����������2����������2���������� ���������� �
����������2��������/������<2�)�����*�
�������������##�������$������� -
%

��	��,��?��!�����	����������������������
��������������
K���������������� ��������������� �����������������������������������
����������%�

n .������� �������������������������������������������������������%�
B��������������������2���������� �������������������������2����������
���@������%�

K��������������� ������������ ����������������������������������2�
������������������������������������������������%�FB�������������������
��� ���������� ������������������������������������������������������
������������������������������B����������������8�����%G�

n �������������������������������������������� �������������������������
�����Edit Symbol����Edit Description �����������������Edit Comment�
���Edit Title�����������%

n *���������������I���� ���������������������������������%�B��������������
������������������8�����2������������������������������%��������� ����
������������������������������������������������ ���������������
������%
��������������������!"���#�$���6��-7



n *������F���2����2������G����������������������������������%���������
���������� �������������������8������� �������%�.���
���� ��������F������������������������  ���������������� ������
�����������G���������������������� ����%�B�������������������������
������������������������������8�����%�.������ ��������������������
���������������������������������������������������������������������Goto 
DataBase%�

n /������ ������������������������ ������������������������!"���#�$�
�����!"���#�$		����������������������!"���#�$�������������2�����2�����
���������������������������������������������� ��������������������� �
������������������������%�F.���������������������������������������
���������%G�.�������������������������������������������������������
������������� ����������%�K��������������������������������
������������������������������������2��������� ��������������������%�

n E��*���������@#��������������������%�!����Tools > Database > Edit 
Using Excel%

3�������� ��������������������� ���������#��������������������/������52�
"+������������������������#�$
+���������#���*�	�������� $9%

��	��:��?��@	��
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'��������������������������������8��2������������������������������� �����
��������������������������������8��%��!����Edit > Verify File����Verify 
Project%�

.�����������������������������2����A���������������������������������������
�������������� ������������ ����������� ������������� ������������������
�������������������� ������%��

Double-click an error 
message to go directly 
to the relevant location 
in the code.

To hide this window 
when finished, select 
View > Results.
--��6����!"���#�$�������������������
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�"/�$�����������������  ����������������������� ���������������%�F3���
!����/���������2��������������"/�$�&?>2�� ���&?>����������2�����!"/�$		�
&?>%�B������������������������������������&>�/����������������������8���
��%G

��������������  �����������������(

�� B��������������/������/������������������������/������������������
������8�����%�

�� @���������������������������������������OK%�

��	��<��?����"����������������	��

������������������������(

�� !����Comms > Download������������������������������������ �
�����������������%�

Use the Channel 0 tab 
to configure settings 
for RS232/422/423.

Use the Channel 1A - 2B 
tabs for DH+, Scanner, 
Adapter, or Inactive I/O 
channel mode.

Use the Channel 2 tab 
(not shown) for Ethernet 
or Local I/O Extension 
channels.

Use the Channel 3A tab (not shown) when 
using a VME or Ethernet sidecar coprocessor.

For more information about the parameters on 
the dialog, click the Help button or press F1.

Tip &��������������������������� �������2�����#� ���������������
� ������ �������2��������������������������������������
������ �����������������������F���G���������� ������������2�
���� ���������������������� ���  ������������������ ������
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 ��������������������������������������������������������
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2���������������� ��������������� ����
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�� .���������������2��!"���#$���������������������������������%��/�����K��
�����������%

&������������������������������������������ ��������������2����������2����
�������������������������2������Comms > Partial Download%��������������
������� ������������������������������"/�$������� 2����������������������
�����%
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'���������� ������������������������2��������(

n ������������������������������������������������

n ���������������������������

n ���������������������#

n ���������������������������������������������

n ����������������

n ;�������8� �������������������������������������������

n ����������������

��� �����������2��� �������������������F��������������G����������8�����%�
K����������� ������������������������������� ������������������ ��� %�
����������������������������������������������!"���#����8��2���������
���������� �Window > Arrange%

B����������� ������������������������������������������������ ����
���������������������%��

B����������� ��������������������������������������������������� ����
�����������������������������������������������%��

Cick here to change the 
processor mode or go 
offline.
-9��6����!"���#�$�������������������
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�� ���������%��*�������� �������������������� ������������������������
/������7%
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�� �������������������� �����%��K������������������������:�����������
����������������� %��&������������������ ��������������������������������
������������������������2���������������������������%�K����������
������������������������������������������%��

���������F���������G(

�� !����Search > Find����Search > Replace%

�� !���������������������������������������������3����'��������%�K�������
�����������������������(

n ��� � �����F��������L&/�����>,G

n ����������F��������)9?-G

n ���� ����������������� � ����������������FL&/�)9?-G

n ���� ������������ � ����������� ����FL&/��@�@.�G�

�� &����������2����������������������������������������������������
������'��������%

�� !��� ����������� ��������������������������F�����������������
��������G�����������Find Next����Replace%�3��� �������� ������������
�����������������������������������2�������Help%
An alternative method for 
searching is to click inside this 
box and type the numeric or 
symbolic address or the 
instruction mnemonic you want 
searched.

This is a tooltip. To see the function of an item 
on the toolbar, point to it without clicking.
��������������������!"���#�$���6��-�



��	��7-��?�����������	����
K������������������������������������� ���������������8��2��������������� �
����2���������������2������������������� �����%��

����������������(

�� !����File > Report Options%����������>����������������������������
������������������� �������������������������������������F�������2�
������������ ��������������2�����2�����2������2�������2���%G%����������
������������������������������������������������%

�� E�����������#����� �����������������������������������������%

�� /�����Page Setup�����������������:2� ������2���������������%

�� &�������2����������� ��������������������� ��0���������%�3���
#� ��2��������������������� �3������������2������������������
������������������������������������� ���������������������������������
�����������������%�

&�����������������������������2�����2����������2�����������������������
����� ��������������������� ���%

�� /�����Print Preview�����������������������������%�K���������������
���� ������ ����������� ��������������������������������������
�������������� ����������2������������� �������������������������
�������������2���������������������������������������������%�

�� &�������������������������#����2�������Print������������������%�
>������2�������Options����������������������>������������������
 ���������%

&��������������������������������������������2�������Save/Load�������
����� �������������>�������������%�,�������������������>�������
!����"���?!�����������������������������& ������������@#������������
����������������� ���������#�������������� ���������������������
���8���%
-,��6����!"���#�$�������������������
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������������� ������������������������������������!"��#�����!"��#�"��%�
&�����2����������������� ������������%�������������������������!"��#�
���� �������� ���������������������������%�F!����driver configuration����
����!"��#��������#G%

�� !����Comms> Who Active Go Online%

�� E����������������������������������������������������������������
�����������������%�

�� /�������������������������������������������%

��	��-��?��%�������	
�� /��������Online�������%

�� ������� ����������������8������������� ���������� ���������
��������������� %�>��������������������������(

n .������� �������������%�&����������2��!"���#�$�������������������
���������������;�����������������%

n .��� ������ ������������������������ ������8������������������
����������� %�&����������2������������������8���������� ���������
�������������Upload Logic, Merge with Existing File’s 
Comment/Symbol DB�������%

n ,�� �������������%�&����������2����������Create New File�������%

Tip �!"���#�$������������������������������������� ���;�������
������>�����,��%�!��� ���  ����������� ���������������%�
!����Comms > Online Now%�&������������������ ��������
����������� ��������������������2����������������������������
���� ��������%�����������������������������#��������������%�*���
����� ���������������������������������%
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n E������ ���  �����������FComms > System CommsG���������������
��  ������������������������������������������������������������������%�
����� ����������  ����������������������������������8��%�&������2�
����������������������������� ���������������������������������
���8��%�3���#� ��2����� ���������������������#����������8������ ���
����������������� ��������������8�������� ����������������������
��������%�

n E��������������  �����������F����������������������������/���������
�����������������������8�������������������������Controller 
Communications����G�����������������������������������������������
�����������������������8��%�>���������������������������������������
�� ��������������������8���������%�K������������������������������
����� ������������������������������������������8����������������� �
��  �������������� ��������������������������������8��������
����������������%

&�����������������  �������������������������������������������#������
�����������������������  ������������������������������������%�K���
������������������������������������������������������������������������
�����  ��������������������%�&���������������������2�8���������������������������
������� ���%
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������������������� ����2��!"���#�$�����������!"��#�"�����  ����������
�����������������������������!"���#�$��������%

K�������������'���.�������� ���������� ����������������  ����������%�
&������2����/�  ��������������������������������Comms > System Comms�
������'���.���������%�&��������������Apply to Project���#2������������
�������������������������  ������������������������������� ����� �
��  ����������%
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&������������������������������������������������������������������������
���� ��������������������2��������������������������������������������
�"/�$�.%&%�!����������������<�		�!�����"/�$�������  ������������
�����������������������%

�� !����File > Open%

�� E�����Look In���#������������������������������������8������%

�� &�����Files of Type�����2�������������������8��%��!"���#�$����������
%�!�2�%L$2�%.3$�����%�/$�������������2����������������������%

�� /�����������8����������������������2�����������Open%�
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*��������������������������������������������������������8���
������������������������������������%

�� '����������8�������2������Tools > Database > Native Import%

�� !����.&��������Import input format%

�� !��������������������������� �������������������������������������
����������������#������������������%���������3
���������������������
���������%

�� /�����OK%

�� 3�������%B!/�����������������8��H��������������������%

�� /�����Open%����������������������������� ���������������������
���8��%
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'���������� �������������.3$����8���������������B>!������<�		�
!�����"/�$�������  �����������2��!"���#�$���������������%�&��
���� ��������������������������������������������������������������.3$�����
��������L$���� ������%��������� ������������� ���������������� ���������
���������������L$����%���

!� �� �2������������ ��#���������������8����������������������������
����������2����� ���#������������� �����������������%�K��� �������������
�!"���# $(

n ���������������������������� ������������������������������F��������
�������� ����G

n ��������� ������������.3$����8������

&�����������������������������������������������<�		�!�����"/�$�
���8������������������������ ���������������%

�� E��������<�		�!����B>!�������  �����������2��������<�		�!����
�"/�$����8�������������L$����%

�� &���!"���#�$2������File > Open%
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�� E�����Look In���#������������������������������������8������%

�� &�����Files of Type�����2�������"/$������� �FP%L$G%�

�� /�����������8����������������������2�����������Open%�F���
���� �����������������������%�&�� ������� ������������������#�%G

�� !����Tools > Database > Native Import%���

�� !����.)�<�		��������Import input format%

�� *�������Import ALL���������%

�� /�����OK%

��� E�����Look in���#���������������������������������<�		�!�����"/�$�
�������������F>�Q�#������G%�/�������������������2�����������Open%�
>������.%&%�����<�		����8������������!"���# $���6��88
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 ����������!"���#�$%

��	�����������$�	�
�����������������������������������������������2�������2����������������
�������2����������2�������������&?>� �����%������������������������������
���������&?>�/���������������������������8�����%

E����������� ����������� ������������ �������������/�����������%�

������������������������������ ��������������������������������������������
&?>��������2����������(

n ��������������

n ������������F���������G���������������

n �����������������������������������

n ������������������ �����������������

n �������2������2�������������� �������������������

n ������������������������������� �� ������&?>

3����������2����������� �������������������������������������������������
��������������������������&?>R�������2����������������&?>������������%����
�������2���������Show Non-I/O Rows�������#�������������������������
����%

������ 4��������������������
4�����������������������6�8�



!����������
�����������������
)���������������������������������8������������������������&?>��������%�
K�����������������������������������������������#���������� ������&?>�
 ������������������������������%�.���������������������������������������
����������������������������������������8����������� �����������������B&��
��������������%�

&RQWURO1HW�XVHUV��3���/������,�1��������2�����������!,����#1����
�����2��������� ������������������ �����%���������!"���#�$����
������������ �����%

�����������������������������(

�� 3�� ����/������������������������8�����2����������������&?>�
/�����������������%����&?>�/���������������/�������������������
������%��

�� ������������������/���������������������Add Chassis%����@����/�������
������������������#�������2���������/����������������%

�� !������������������������������������������������������%�.���������
������������������������������������%

�� !������������������������ ��������%

�� &�����0����������3�#�&?>��������2���������� ������������������
Number of slots�����%�@�������������� �
����7%

�� B��� ������B&�����������������������������������������������������
����������������������#��������B&��!�����������������������������#%

�� /�����Apply������������������������������������������#��������������
OK�������������������������������������������#%�

To change or redefine a 
chassis, right-click on it and 
select Properties.

To stop an I/O 
chassis from being 
scanned, check Inh.

To reset scanning of 
all I/O in the chassis, 
check Res.
8,��6����!"���#�$�������������������
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������������������2������	�
@����&?>����������������&?>�������%����������������������"/�$���������2�
����������������������������8��2�������&?>�������%�!������������B&��
��������������2������������������������������2���������������������������
�������������������������������������������������������������������������
�������������/������������F������������������������������PropertiesG%���

0��������A�B

0�������2������	�B

Indicate the dip switch 
settings of the chassis.

Select the I/O adapter 
type from this llist.

Make your selections for 
the scanner PLC and 
scanner channel here.

Indicate the dip switch 
settings of the chassis
4�����������������������6��8:



!�����������	��
��������� �����������������(�

�� B��������������&?>�/���������������������������8����������������
/�����������%

E�������� ���������2������������2����2�������� ���������������������
����������������������%�!� � �������;������������������������������
����%�

�  ����������������������������[F1]�������������������������������
��� �����������������������������������������������������!"���#�$%

�� Right-click the 
chassis and select 
Display Chassis.

4. Select the module 
type and the specific 
module. Click OK.

�� Right-click the cell for 
the slot you wish to add 
a module to and select 
Insert Module.
8;��6����!"���#�$�������������������



���
����������
���������������&?>� ����(

�� B��������������&>�/���������������������������8�����%�

�� ������������������������������������� ������������������������������
�����Display Chassis%�

�� ��������������� ����������������������������������������Display 
Module%���� ����������������������������������� � ��������
 �������������������������������������������������������� �����%�
�����[F1]����������������������������������� ����%�

n 'LVFUHWH%����� �������;��������������������2������� ����2�
�����������2������2�����������������������������������������&?>�
������%�/�����Close�������������������%�

n $QDORJ%�*����������� �������;�����������������%�����������������
�������&?>� ������������������S�����������������������T� �����%�
&���������������������������������������?����������2���������������
���� ���� �����������2����������������2����� ��� ���2��������������
����� ���������������������������������� ����%�

����������� �����������������������������&?>� ����2����@����
*�����.��������������������%�@���������������������Auto-Pick�
��������!"���#�$����� ��������������������������;������������
 ����2���������������Done%�F.�����������������������������
/������,�� �����%G������ ����0�����������������������������%�
*��������������2�������Accept Edits2�����������Close%

&�������������������������������������2����������������������������
�������������� ����0��������������������������������Edit Variable 
Addresses%

Tip *����������� �������;�����������������������%��!"���#�$�����
���� ��������������������������������%�>������� ����0��
��������������������2����������Insert Ladder Rungs�������%
4�����������������������6��8<
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�����������
������������������������� ������������������������� ���������������������
����������%�

3��(������������"��(�
�  ������������������������������������������������������������ �%�
�!"���#�$�������������������������������������������������������������� 2�
������������������������������������������������������������������%�.���
��������������������������������������������������������������������8��%

n $XWR�%DFNXS������������������� ��������������� ��������������8��%����
��������� ���������������������������������������8��2������Tools > 
Options��������������Preferences����%�@�������� ���������Number of 
Backups�����%�

.����������������F��������%�!������G��������������).D���������������
�� ����F			����===G������������������� %�3���#� ��2���������
��������������������8����@!�%�!�� �������������������
�@!�U).D			%�!�2������� ��������������� �������������������
�@!�U).D		
%�!�%�

������ *����������������
�����������

Tip !�������� ������#�������� �����������������������������!"���# $%�
.�����������������F�����������������G������������������ ������
��������������������� ������������������������������������������
���������%����������������������������4������������������8�����2�
�����������������������E��������D������%���
.%&�!����������  �������������������������!"���#�$%����
������.&�/�  �����������@ �������2������[Alt .]%��������������
������������  ����F��������@&����������������G����������[Enter]%�
3��� �������� ��������2���$�++��#	������� -$%�
*������������������������������6�97



n &RPSUHVVHG�)RUPDW�%DFNXS�������������������������������������������
��������������������%�/� ��������� �������������������������%�!������
���������������������������8����� �������������������%��
����%�.��������
����������������� ����������������������8������������������������������
�� ������������%�������������� ��������� �������������2������
File > Backup Project%

����������������������������������� ��������� �������������2��� ����
�����File > Open������������%�!�������������������%��
����%�

�������	���	���
&������#������������������������2��!"���#�$�������������������������
���������������������������������%

�!"���#�$����� ���������������������������������8�����������������������
�������%�F������Tools > Options2�Preferences�������������������������������
����.���!���������%G�����������������������������F���������!�����G����
�������������������������#���� ��������������8�������������������� �������
�������������������������%�'������ ������������������8���������������
��������!"���#�$���� ������������������������%�

n K��������������������.���!�������������������%����������������������
F��������#�����������������������������G� ����������������� �������
�����.���!������������������%�>�������������������������� �������
��������������%

n K��������������������������������������������%������ �������������
����������� ��������������������� �����������������������������
�� ����������� ������������������%

����������
�����	��	�����
�!"���#�$��������������� �������������������������������������(�C�����
D��*������2�.!/&&�������2�����.%&%�!���������������  ����%�

Important K��� �������������������������������������������������������
����� ����������������������������������%�������2������������
�����������������������  �����������������������������8��%�
��������������������������������������������������������%
���.���!�������������!"���#�������������������������2�����
��������������������������������������������������������
.���!��%
9-��6����!"���#�$�������������������



'���(�C	��)�������
��� ��������������  ���������������2��!"���#�$��������� ����������������
�������������F.�VG����������� ������������������������������
������  ���������������%

����������;��������(

�� !����View > Properties�F ����������������������� ������������
��������������������������������������������������������� ����
A��� ��G%�/��������Quick Key Mapping����%�

������C�����D��(

�� /�������������� ������������������������������������������������
����%

�� !����Edit > Quick Key Mode2����������������[Ctrl-E]���������
�������%���������������� ������������������������� ��������������
�����������C�����D��*��%�.������������������������������������
"�����A��%

�� �����������������;���������������������������������������������%����
������������������������������������������������������������������
;�������������� ���%

�� ���#���C�����D��*��2����������Edit� �������������Quick Key 
Mode2���������[Ctrl-E]������%�

�� Double-click _Free 
anywhere in the 
Instruction column. 
(Or double-click an 
assigned instruction 
to change it.)

�� Click the arrow to 
open the list box.

�� Click the instruction 
you want to assign.
*������������������������������6��98



!�����	������
.!/&&�@�������������������������!"���#�$�������������� �������������������
������.!/&&������������� � �������������������������� �������������������
��������������������%

�������������(�

�� !�������������������������������������������� ������������[ / ]%�
*�����������������������������������������������������������%�K���
������������������������������� �������������.!/&&���#%

�� .��.!/&&����������#�����%�3������������������������������������2����
#�������.!/&&����������������������������#������������������ %�.��
����������������������2��������#��������������������������������
���� ���%

�� �����[Enter]������������������������������������[Esc]������������
�� %

6�����	�!���������

.��� ��������������������������������������������.!/&&���� �������������
��������������.!/&&� � ����������������������������������������������
����%�

Cursor

Syntax guide
The parameter you need to 
enter next (or are entering) is 
highlighted in bold.

�)!��L&/�&(		9?
9�,L)�L&>��-(�	?B,�),B�L&>�)9?99��>,��-(�	�	%	
�$		�-
��

BST = branch start
NXB = next branch
BND = branch end
99��6����!"���#�$�������������������



������������
&��.%&%�!������������������  ������������������������� ����������������
������������������2��������������������������������������������������������
���.�������B��������������������'���.����%��!"���#�$� ���������.%&%�
!����/�  ����������%�

������������  ���������!"���#�$(

�� �����[Alt-.]2��������2��������������.�����������������������%

�� ���������������������  ���%�3���#� ��2�����EI�F@����&����G����
������������%

�� �����[Enter]%

3�������������������  ������������������������%�!����Help > Contents%�
/��������Index�������������dot commands%�/�����Display%

���	�������������������
�  ������������������ ����������������������������������������
�������%���������� ��������������������������������#�� ��������������
��������������%�D���������������������[Shift + F10]������������������ ����
 ��%�

�  ���������������������[F1]�F������������4����������������������G�
������������������2����������������������������������%�3��� �������� ������
������������������/������
	2��������������&��+������(�
����#������� 55%

�	�	�������������	��������
K������������ ��������������������������������/���������������������������
 ���������������������������������������%�K���������������������������
�������������������������!������������������������������������������
����������%

D�����������������

K�������8� �������������������������8��������������Search > Goto%�K�������
�������������������������������� ���������������������������������������
������ ����������������� ����8��%�K�����������������[Ctrl + G]����������
�������������������%

Tip K��������� ����������  ����������.!/&&�����������������������
�����������%������[Alt - .]2�����@&2�@.2����@����������2������2����
������������2���������������������F ? G�����������������������2�
�������.!/&&�����2����������[Enter]%�3���#� ��2�
@&?L&/�&(		
?
�>�@�>(		�?$%
*������������������������������6��9�



C	�$����������������

.�����������������F�����������������G������������������ ���������
������������������ ���������������������������������������������������%����
��������������2�#��������Help����������������8�����2���������������
���������Using The Keyboard%�

!�	�����
K������������������������ ����������������������������%�K�����������
������������(�

n  ��������������������

n �������������������� ����������

n ����������������������� ������� ���������� 

3����������

!���$�������
/��������������������������������������������������������������������������
�����%�&����������������������������������2���������������������  ����������
��������������������������%�&������������������������������ ��2��������������
����������������������%

)��	���$������
/�������������������������������������������������� ������������������
������������������������������������������������������ %�A�����������������
���������������������������������%

6�������$������
/�����������������������������2����������������������������������%�A�����
���������������������������������������������%

Tip K��������������������������2��������2�������������2�������������
��� ������������������ ��������������������%�����������������2�
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Edits are made on the duplicate 
rung, marked e.

r marks the original rung, which 
will be replaced by the edit rung.
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The upper-case I represents the 
rung that has been inserted into 
the online program.

The upper-case R represents the 
online rung that is to be replaced. 
At this time the R rung is still 
operating in the program.
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�� /�����RSLogix 5%

�� !�������������������� ����������� ����%

n ��������� ���������������������
�9��6����!"���#�$�������������������



n ��������������  ����

n �������������������������������

n �� ����������

�� !������������������������������������������������>D%

�� "������������������������������������������ ���������������Open%

)������������������������������� ��������%/�B%����%/�B�����������
�������������������%�&���������������������������������F����#� ������
�� ���?�����������������������������?�������������������G�����������
�������� ����������������%/�B����%�.�������� ������� ����2��!"���#�
$��������������������������� �������������������������������������
� ����������������������������������������������������������
��������������� �����%�3������� �������������!"���#�$�����#��������
��������������������������� ��������������������������������������
S����#�������%T�

��@�4�������	�����	�@���	�5�
��	�
K��� ������������ ����������������������������������������������������
*���������@#�����������#��������� ��"/�$�.%&%�!���������������%/!A�
��� ��%

���� �������/!A����(

�� !����Tools > Database > ASCII Import%

�� /�����CSV%

�� !�������������������� ����������� ����%

n ��������� ���������������������

n ��������������  ����

n �� ����������

�� !������������������������������������������������>D%

�� "������������������������������������������ ���������������Open%

3������#� ��������%/!A����2�������������������������������������#�����
S/!A���� ���������������� ����?#����%T

!�����	�����	��	���
��	
K�������� ��������� ����������������������������������!"���#�$�
������������"/�$�.%&%�!����������������#������������������.!/&&�
��� ���������F%@.!����.%&%G%�.!/&&���� ���� ��������������������������
�!"���#�$����������������������������;���� ��������������������
��  ��%�
& �����������#��������������� ������������������6����



���� ��������.!/&&������������(

�� !����Tools > Database > ASCII Import%

�� /�����RSLogix 5%

�� !�������������������� ����������� ����%

n ��������� ���������������������F%@.!�����G�

n ��������������  ����F%@&/�����G�

n �������������������������������F%@�������G�

n �� �����������F%@!������G�

�� !������������������������������������������������>D%

�� "������������������������������������������ ���������������Open%

.�������#������� ����������������.!/&&���� �����#�����%�K�������
��������������������������#������2�����8�������������������%

.��#� �������������������������2���������#���������������������������
����������������������2����������������������������-��""�#���+���#������&����
���+���	�����������������$5%

6���������$��	
E�����#�����������������������!"���#�$���� ������������������ ��������
�����������������������������!"���#�$����8�����������������������8���%�

���#��������������(

�� !����Tools > Database > ASCII Export%

�� /����������������������������������� ��(�RSLogix 52�A.I.2�AB 62002����
CSV�F��  ��������������G%

�� !�������������������� ����������#������������������������ F�G%�
/�����Help����� �������� ������������������������������������������%

�� '���#��������������� �������������������.%&%����.)�<�		���� ����
����� ����2������������2�������������������  ���� ��������������
��������:�������������� ������������"/�$�.%&%�����<�		�!����
��������%������ ����������������������������#����������%�!�2�����������
�����������������������������������������������������!"���#�$�
�����"/�$�.%&%�!����������  ����������������������������
������������#�������������2������Treat Source Description as 1 80-
character line%�

.��������������#�����2����������������.!/&&�������������#�������2���������
��������������������������%
�,��6����!"���#�$�������������������



����������!�����	�����	��	���
��	�	�����	��
���#� ����������������������������������� ����������������
��������������#������.!/&&��#����������������!"���#�$����������� ��%�

@���������������������.!/&&��#���������������;����������������������
��  �%�@ ��������������������������;������������������������� %�

!�	������$�������	�����������4*6!��
��	�5
"B3/0","0","SYMBOL","description","","","","","0","","","0","GROUP_NAME"

���	�����	���������	�����������4*6���
��	�5
"RUNG000002-000002","page title","rung comment\"

$6&,,�)LHOG�� 0D[LPXP�/HQJWK &RQWHQWV


 9=���������� .�����

� ,?. !����F	X������2����$$X������������ �����
�� ��

9 �	���������� !� ���

- �	���������� B��������������


$ �	���������� B���������������

< �	���������� B��������������9

5 �	���������� B��������������-

7 �	���������� B��������������$

= 
����������� B��������F�������	���������������������
��������&?>G


	 =���������� B�������������������



 =���������� B�������������������


� ,?. B�����������������������F	X�����2�

X�������G


9 �	���������� !� ������������ 
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 9=���������� B��������������������������������

� 7	���������� ��������

9 <-D ���������������
& �����������#��������������� ������������������6���:



����������������	����4*6���
��	�5
"B3/0","XIC","instruction comment","","","",""

���$����������4*6�%�
��	�5
"GROUP_NAME","description"

!*�*�!�����	�����	��	���
��	�	�����	�
����#� ������������������� �����������������.!/&&��#������#������
���������.%&%����������� ��%�@���������������������.!/&&��#���������������
;������������������������  �%

!�	������$�������	�����������4*6!��
��	�5
"B3/0","0","SYMBOL","description","","","","","0","","","0"

��������������������.%&%�.!/&&���� �����#���������� ��������������
�!"���#�$�.!/&&����������� ��2�#��������� ����������������������������
�� �������
$��������������������������� ��������������%

���	�����	���������	�����������4*6���
��	�5
"RUNG002-0002","page title","rung comment\"

��������������������.%&%�.!/&&���� �����#���������� ��������������
�!"���#�$�.!/&&����������� ��%

$6&,,�)LHOG�� 0D[LPXP�/HQJWK &RQWHQWV


 9=���������� .�����

� 9���������� &��������������

9 �	���������� /�  �������


- �	���������� /�  ��������

$ �	���������� /�  �������9

< �	���������� /�  �������-

5 �	���������� /�  �������$

$6&,,�)LHOG�� 0D[LPXP�/HQJWK &RQWHQWV


 �	���������� !� ������������ 

� 7	���������� !� ��������������������
�;��6����!"���#�$�������������������



!3�,-..�!�����	�����	��	���
��	
.)�<�		����� �����������������������������.!/&&��#����� �����������
�������%�D������������������������������������ �������  �������
��������������������������������  ��2������������������  ��2�����������
��  ��2�������� ���%�!� �#� �����������������%�
SYM B3/0 SYMBOL

SYM O:17/03 UPLOAD

AC B3/0 “description”

AC I:21/03 “AIR STOP CLOSED LIMIT SWITCH\”

IC XIC N7:10/0 “Surge Tank High Level Alarm”

RC CTD C5:0 ” (carriage return)

This is an example of a rung comment with quotation\ marks

and carriage returns at the beginning and end.

” (carriage return)

C	��+���

�������������������.)�<�		����� �����������������������(

!K*�W��� ���

./�W����������  ���F����������G

&/�W���������������  ��

�/�W��������  ��

3/,�W�!3/��� 

3/&�W�!3/���  ��

&>!�W�&?>� ������� ���

&>.�W�&?>� ��������������  ��

&>/�W�&?>� ������������������������ �����

��@�4�������	�����	�@���	�5�
�����
!�����S/!A���� ���������������� ����?#����T��������!"���#�$�����������
���#������� ����������%
& �����������#��������������� ������������������6���<



,.��6����!"���#�$�������������������



������������
&���������������������������������������������������������� ������������
������������2��!"���#�$����������������������������� �:�� ����������
 ��������������%���

n /����������

n 3����

n /���� �B����*������

n �����*������

n /���� �����������*������

n 4������� �

n �������

�������� ������ �������F/B*G��������������� ��������������������������
���� ���������;�����2�������������������������������������������������2����
����������������2����� ��2�������2�����������������������������������
��� ������������������%

'���������������2�������������������� ��������������������������
������ ������������������ 2����#� ����������������������� ������������
�"/�$���������%�.����������������������� ������������������F����������
�����G������������������ %�/���������������������������� ���������������
������������������������������������������������� %�

������ *��������� ����������
����
*��������� �����������������6�,7



�������	
	�	��	�
.�/������������������������������������������������������8������������
�����������������������������������������%���������������������
��������������(�������2��� ���2������������� � ����2�����N�F������ G2�����
�����N%�K���������������/���������������������� ����������������%��

B���������/����������������������������������(

n B��������������/�������������������������8������F������B����3����
�����G%

n ���������������������������������������������������Cross Reference%����
�� ���������������2������������������������������������������%

.��������������������/����������������2��������������������������������
����������� ���������������������������%�����������������2������View 
> Properties2��������������Address Display����%�*��������������������
������#�����������������Cross Reference Display�����������������%

Tip K��������������������������������������������%�!����Tools > 
Options%�/��������XRef/Address Wizard�������������������
Enable Cross Reference Online���#%
,-��6����!"���#�$�������������������



0���	��

��� ������������2��������������������������������������������������8���
��%

K������������������3�����������������������������������������������������
������� �������������������������2�������������������� �������� ����������
��������������%�E����������������� ������������������3��������������������
����������������%�3��� �������� �������������������2��������������������%�

������������)�������4��)5�
���/���� �B����*����������������������������� �����������������������
������������%�

.����������������� ������ ������������������ ���� ������������������%�����
������������������� ������ ��������������%

3����������������� ������ �������������(

n /B*������������������������������������%�&�������������������������
��������2������������� �2���������#���������������������������  ���%

n /B*�������������������.!/&&���  �����������������������������������
��������2���������������/B*����%

n K�������������������$<�F/B*G�������������8���F	��$$2���������G%�

n ���/B*��� ������ ��������	����������%�

n ���/B*����������������� �������$=����������%�

n K��������������������������������� �������������������������������������
���/B*%

n K�������������[Ctrl]�����[Shift]����������������������� �����������
�������������� ���� ��������������%

n K��������������������������������� ����/B*%

������������/���� �B����*������������2����������������/B*����������
����������������8�����%�

Caution .������������������������������������� ������ �� ��2�
�����������8�����������������;��� ��%�E!@�@L��@*@�
/.E�&>,�'4@,�E!&,��3>�/@!M

By default an untitled CDM file (#0) is included 
in your project. Rename this file when you add 
your addresses.

To create a new CDM file, right-click the 
Custom Data Monitors folder and select New.
*��������� �����������������6��,8



��������������������������������� ����������� �����������������[Insert]%�.�
�������������������������������������������������������� ������������
������ ���������������������� ����.����������%������������������������
����������������������A�������� ��������������������������%�&���������������
�����������������������������2��������������������%

3��� �������� ������������������/���� �B����*������2������[F1]���������
/B*����������������%

�	���	�)�������
��������*����������������������������/���� �B����*������%���������
*������������������������������ ������������������������������������������
���������  ������#%�

*�����"/����8������������������������������������� �������������������
�������� ��������������%�'��������������������������������������
� ���
�������������������������� ���
���������� ��������������� ���
��������
2�����������������������S����T%�����������������������������
�������������������  �����������������������������������������������
������������������%���������*�����������������������������������
�����������������������������������%

�����������������*������������2�������������������������������������
���������8�����%��

3��� �������� �����������������*������������[F1]��������������
���������������%

By default an untitled Recipe Monitor file (#0) is 
included in your project. Right-click and select 
Properties to rename this file.

To create a new Recipe Monitor file, right-click the 
Recipe Monitors folder and select New.

Drag a data file from the 
project tree to the 
Recipe Monitor. Note 
that an asterisk ( * ) 
represents the indexed 
part of the address. 
If you type in or drag an 
address from the ladder, 
be sure to use an 
asterisk to indicate the 
indexed part.

Set the index value.
,9��6����!"���#�$�������������������



�������%���������)�������
���/���� �����������*����������������������� ���������������/���� �
B����*������2�����������������������������������������������%����/���� �
����������*��������������� �����������������������.����L��������������
�������2�������2������2�����������������������#������� ������� ���%�.�����
�����������.����L���������2������������������������������������������� ����
B����� ��������������������� �������������������������%

������������/���� �����������*������������2����������������/�&�����
���������������������8�����%���

1����������
E������������� �������������������!"���#�$������������ �������������������
������I������������������������� %�

By default an untitled Custom Graphical Monitor file 
(#0) is included in your project. Right-click and select 
Properties to rename this file.

To create a new Custom Graphical Monitor file, right-
click the Custom Graphical Monitors folder and 
select New.

Click one of these buttons 
to add text, buttons, 
sliders, gauges, images, 
or graphs to the form.

Click here to toggle 
between Run and 
Design mode.

Displays the 
current mode.

Drag an address from 
the ladder or data table 
to a control.

Right-click a control and select Properties to change 
colors, define ranges, and set other options.
*��������� �����������������6��,�



K��� ���������������������"/�$������������������������������ ���������%�
!����Comms > Histogram���������������4������� �������%�

)�����������Start���������������2������������ ����������������� �����������
�"/�$������������������������������%�@������ ����������������������2�
����������������������������������������������������� ������2���������
������������������������� �������������������������%��������������
���������������������������������������� ���������������%

&��������;���������������������2������������������������������������ ����
������������������������������������� ���������� %�E��Save Config�����
Load Config2������������� ���������� ���� ��2�����������������������%

��	���
.����������������������� ������������������F���������������G�������������
����� %�/���������������������������� ����������������������������������������
������������������������ %�

�������������������������������������!����L�A���������� ���
������������������%�����!����L�A����������.����L������������������������
����������������������������������������������� ��%�&����������������A����
���������������!�����B����.�;����������������������������%�

Enter the address you 
want to track.

Select a time base for the histogram (in 
seconds).
If you don’t see data values changing, 
the time base may be inappropriate for 
the address you are monitoring.

Histogram

Timing Chart
,,��6����!"���#�$�������������������
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�� ������������������������������������8���������������,�%

�� �������� ��������������������������������,� �����%�����������>D�
����������� ���������%������ �������������7	�������������������%�
.�����������������������������������������������������������8���
��%�'������������������������������������������������������%�
�������������������������8��%�"�����������������������%�

K�����������������������������������������������������%�K��� ������
������������������%

�������������#� ������������������������ ���-(=%��

���������������������������������������������������(

n .����������#����������������������%��������������������������
�����������������������#������������������������������� �������������
�����������%

n ����� ������ �����������������%�&�����������������2������ ��������
�����������������������������������������������������������%

n ���������������������������������%�,?.� �������������������������
���������F���������G����������������%

Drag addresses, rungs 
or symbols to the chart 
from the data tables, 
ladder logic, 
Address/Symbol editor, 
or Address/Symbol 
picker.

Right-click on the graph and select Chart Properties to configure the chart. 

Tip ����������������L������������� ��������������� �����2�������
���������������������������Chart Properties%�/�����Help%������
������������L������������������������������������%�/�����
���Help Topics������������������������L�������������
��������������#%
*��������� �����������������6��,:



,;��6����!"���#�$�������������������



�����������
�/$�����������������.!/&&��#����������������������  ��������������������
�����������2�!3/�����2������������#�2���������������2���������������%�)��
#��������F�������������G������ ��������F���������������������8��G������/$�
����2�������������#�����������%��/$������������������������.!/&&��#��
���������� �������������������������8���%��

�����������	�	�$	���$������$�����
��	�
n >��������������8������������������������%�/$����%

n @#�������/$������������������������ ��������������	�������������������%�
'���� �����������/$�������������"/�$�.%&%�!���2��� ������������
������������
$����������%�3���#� ��2������ ������ �
E,">.BU!��&,�U&,B@L���������������������
E,">.BU!��&,�U&%�

n ��������������������������������%

n &��� ��������������"/�$�.%&%�!�������<�		�!�����������2������ �������
%�/$���������� ���������������������%�&��� �������������<�		�!�����������2�
��������.�V2�	�=2������������������������%

n �������#�������������.!/&&����������  �������� �������/$%

n K����������� ��������#�������/.��F����� �������������������G����%

n &�������������������������������������2��������������������������
����� �����������������������#����������������� ������������:��
���������������%

n ����#�����������������������.!/&&��#������ �������������������������
.!/&&����������2���������������������������������������������%

������ !������������������
���������  �������
�/$���������
!���������������������������  ��������/$������������6�,<



6�����������$����	�
K�������������������8�����������������������%�

����������������(

�� &�����������������������������������2������������������������������%�3���
����������2��������������%�

�� @�����������������������������������Copy to PC5 Library2���������
Edit > Copy To File%�

�� !����������������������� 2�����������Save%

�� !�������������������������������#�����������@#������/$�3�� ���
�����������������OK%��

������������$����	�
& ����������%�/$���������������������������#��������������������������������
���������������������������������#�����2���������������������������������
��������������� ����%�& ����������%�/$�����������������������������
  �������2�����������#�����������%�/$�.!/&&����2��������!"���#�$�%�!��
��� ��%�

���� ��������������(

�� >���������8�����������������������������������������%�&���������
������������ ���������� �� �����������#����������8��2�����������
������������������������������������������������������� 2�����
���� ���������������������������#������������� �����%

Select whether you want to save the 
entire library or just part of it. To save part 
of it, you must have selected the rungs 
you want to save in Step 1.

Checking Annotate Library places 
additional information in the PC5 file about 
the rungs’ position in the original program. 
This information is used for 
troubleshooting a library file, and can help 
you if you intend to manually edit the PC5 
file in a text editor.

If you type a description here, it will appear 
at the bottom of the Open/Import dialog 
when you import the library.
:.��6����!"���#�$�������������������



�� &����������������������������������2���������������������������� ������
���������������������������������%��������������������������������
���������������������������%�B������������������ �����������������
��������#��������������������������������������������������������
����������8��%

�� !����Edit > Paste From file%�F>������������������������������Paste 
From PC5 Library%G

�� >�����>��?& �����������2�������������������������� ���������������
Open%

�� >�����& ������/$�3�� ������������������������� ����� ��������
��������������������� �������� �����������������������������������
#����������� ��������������������������������������%�

�� /��������.������"����*����������������������������OK%�/�����4���
���� �������� �����%�!���������� ��������������� ������������
&��#�� ��%

Choose the Indexed mode and then click Edit Index if you want 
to display a Fixup table from which you can adjust the addresses 
in the imported library so that there are no conflicts with the 
addresses in the base program.

If you change base address B3/5 to B3/10 (in the 
Fixup column) and press [Enter], the addresses 
relative to B3/5 change accordingly. Each relative 
address is offset by the change applied to the base 
address. In this example, relative address B3/9 
would change to B3/14, and so on. Relative 
addresses include all addresses in the list in the 
same data file up to the next base address. The 
address column continues to display addresses as 
they were before you made any changes. 

To change the address type, 
double-click it and select either 
Global, Relative, or Base. An 
address set to Global is not 
affected by indexing to a previous 
base address.
!���������������������������  ��������/$������������6��:7



�����	�����
��	
��������������� ������������������ �������%�&�������������������������
���� �������������������%����������������������������#��������'���-��""������
&���������� 5-����� �������� ���������������������������������������������
����� �����������  ����F�#��������������������������YG%

������������������������������ �����������������������������2���������
��������������������������� �����������������������������������������
�/$������������%

Program Header START PLC5_40VL SERIES_C REV_C COMPLETE

Data Table DATA O:177
% O:000 % 0X0000 0X0000 0X0010 0X0000 0X0140 0X0000 0X0003 0X0000 
% O:010 % 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 

% O:020 % 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 
% O:030 % 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 

DATA I:037
% I:000 % 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 
% I:010 % 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 

% I:020 % 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 
% I:030 % 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 0X0000 
..
.
.

Project Name PROJECT "ICOM5DM7"
2  "MAIN_LADDR"
3  "PID_SUB_RT"

4  "SUB_RT_2"
6  "SUB_RT_4"
7  "BITMAP_CHT"

8  "TREND"
9  "WHEELPROG"
10  "WINVIEW"
:-��6����!"���#�$�������������������



Program Files LADDER 2

% Rung: 0 %
SOR XIC B3/0 XIC I:002/1 OTE O:004/0 EOR 
% TITLE/RUNG DESCRIPTION  ATTACHED TO:RUNG

TITLE:Start Up Diagnostic Check
RUNG DESCRIPTION:

Sample Rung Description 

Rung Descriptions can be up to 64K bytes per rung, with 200 lines displayed
The first rung description might explain the program or give useful information
%

% Rung: 1 %
SOR BST XIC I:003/4 NXB XIO T4:5/DN BND XIC B3/10 TON T4:5 1.0 450 315 EOR 

% Rung: 2 %
SOR XIO T4:9/DN XIC B3/96 TON T4:9 0.01 150 17 EOR 
% Rung: 3 %

SOR LIM 1 T4:9.ACC 40 OTE B3/0 EOR 
% Rung: 4 %
SOR XIC T4:3/EN XIC I:003/0 OTE B3/65 EOR 

% Rung: 5 %
SOR XIC B3/28 BST OTE B3/88 NXB OTE O:004/6 BND EOR 
% Rung: 6 %

SOR BST XIC B3/33 NXB XIO T4:0/DN BND TON T4:0 0.01 500 473 EOR 
.
.
.

Force Table FORCE FO:177

% ON     OFF  %
0X0000 0X0000 % FO:000 %
0X0000 0X0000 % FO:001 %

0X0000 0X0000 % FO:002 %
0X0000 0X0000 % FO:003 %
0X0000 0X0000 % FO:004 %

0X0000 0X0000 % FO:005 %
0X0000 0X0000 % FO:006 %

0X0000 0X0000 % FO:007 %
0X0000 0X0000 % FO:010 %
0X0000 0X0000 % FO:011 %

0X0000 0X0000 % FO:012 %
0X0000 0X0000 % FO:013 %
0X0000 0X0000 % FO:014 %
!���������������������������  ��������/$������������6��:8



0X0000 0X0000 % FO:015 %
0X0000 0X0000 % FO:016 %

.

.

.

Channel Config CONFIG $4:2:-1

CONFIG $4:0:347
% $4:0:0 %

-1 -1 26688 7175 18954 7717 -1 -1 26688 7175 

% $4:0:10 %
18954 7717     -1     -1 26688 7175 18954 7717 -1  -1 

% $4:0:20 %

 26688 7175 18954 7717 0 0 0 0 0 0 
% $4:0:30 %

0 0 0 0 0 0 0 0 0 0 

% $4:0:40 %
0 0 0 0 0 0 0 0 0 0 

% $4:0:50 %

0 0 0 0 0 0 0 0 0 0 
.
.
.

��	���������	������������!������	���
��	
.��/$������������������������#��������(�������� �����2����������2����8���
�� 2������� �����2����������2�������������������������%�

��	��
�������	����������	�	�
����������������������/$����������������� �����%���������� �����������
�����������������������(�

n ���������������

n ����������������

n �������������������

'������������ ����#����2���������� ���������������������������
/>*�"@�@�����.��&."%�������������������������������������������������
�� ���������� ����������������������������������������%�@����.!/&&�����
 ���������������� ������������2��������������� ������������������
 ���%
:9��6����!"���#�$�������������������



������������������� ���������������������������������"/�$?
$������)�
��������.������������������������������� �������������  �������%
START PLC5_15 SERIES_B REV_A COMPLETE

��	��
�������	�������$�	
����������������������/$�����������������������%�������������������������
��������������������������������������%�3���������������(�

n ��������B.�.�F����������������G

n ����������������������������

n ��������� ��

n ������������������������������

E���������������������������������������%

�����������������������������������������������9������������7�������F	�5G%�
�������������������������������������������������������������������%

DATA B3:7
0 1 2 3 4 5 6 7

��	��
�������	����/	������	
����������������������������8����� ����������� ������� �%�������8���
�� �������������������������� �����	%�

��������������������������B�&""
����������8����� ���������������
  ������������*.&,U".BB���������� ���������� ������%�������8���
�� ����������� ��� �� ����������������;���������������������������7�
����������F.�V2�	�=2���������U���������������G%

PROJECT "DRILL1"
2  "MAIN_LADDR"

��	��
�������	���������
��	�
�������������������������������� �����%�@���������� �����������������
�;����������������������2������2���������������#�������� �%�@���������� �
������������:������ ��������%�@����� ���������������������������
������������� � �����������������;������������������������� �����%�

������������������������������������ �����9%���������".BB@��F�����
�����������G�������������������������������� ������� ������������%�@����
������������������������!>���������������������������������������������������
�����H����@>��������������������������������������%
!���������������������������  ��������/$������������6��:�



LADDER 3
SOR XIO I:030/3 XIC I:030/4 TON T4:10 1.0 32000 0 EOR

SOR XIC I:030/3 MOV T4:10.ACC T4:10.PRE EOR

��	��
�������	�
���	���$�	
����������������������������������%�������������������������������
���������������������������������������������%�&�����������������������������
������������������%�

��������������������������������������������������������������>(	$5%����
�����������������������:������������?�������� �������%�

����������������������  ���%�����������  ���2�����������������
������FYG2�����������������������%������������� �����������������������
����������%�

FORCE FO:057

% ON     OFF  %
0X0000 0X0000 % FO:000  %
0X0000 0X0000 % FO:001  %

0X0000 0X0000 % FO:002  %

��	��
�������	������	�����
���������
�����#�����������������������������������������%����������������������
�������������������������� �����������������������������������������
���������������� �����%��������������������������������������������������
�����������������������������������������F�%%��������:������������ ���
����� �������������B4Z�������G%�

CONFIG $4:1:411
-1  -1 8224 8224 8224 8224 -1 -1 8224 8224

8224 8224  -1  -1 8224 8224 8224 8224  -1  -1

8224 8224 8224 8224 257 257 -1 0 0 0
0 0 0 0 0 0 0 0 0 0

!������������	�����
��	
K��������������  �����������/$�.!/&&��#�����%�/�  ����F�#���������
���������������YG�����������������������%������������� ��������������
�������������������%�
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E��������������������������������������������������� ����������!"���#�$�
�������2��������������������2��!"���#�$���������2���������������������%�

K���������������� �������� �������������!"���#�$����������������������(

n �!"���#�$����������

n �!"���#�$���������

n �����������������������

���������������	��	��
�!"���#�$��������������������������2���������������������������������
���������#2��������������������������������������������������������������
�!"���#�$%��������������������������������!"���#�$��������(

n ���������4�����������������������

n �����[F1]�������������������������������������2����������#2��������������

n �����Help > Contents

n #��������4������������������8���������������������������������
����� ���������������F#��������E���.�����������4�����������������
����������������������������G��������������������%

#�������	�����	���F���	�F����0�����$�
������������������������������(

n �����Help > Contents�������������������������������

n #��������Help����������������8�����2�������������Contents2�����������
������������������

������ ��������������� ������
������
��������������� ���������������6�::
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To expand the outline, 
double-click a closed 
book.

To collapse the outline, 
double-click an open 
book.

To go to a topic, double-
click a page.

Double-click the 
Procedures bookt o see 
a list of all the tasks you 
can accomplish related 
to a specific function of 
the software.
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To print the contents of a 
popup window, right-click 
in the popup and select 
Print Topic.
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